Friday, March 19, 2010

No SQL Compact on Windows Phone 7?

The title says it all!

But then again, some clever guy has unpacked the Windows Phone Emulator image, and lo and behold: SQL Compact version 3.5.5722.1 is there, currently not available to applications, but included on the device together with .NET Compact Framework 3.7 -

Thursday, March 11, 2010

2 new Sync Services hotfixes for SQL Compact

Sync Services for ADO.NET for Devices 1.0 has been updated for performance. The initial release of this used DataSet on the device for INSERTs and UPDATEs, which caused large memory consumption and slow performance on the device. The updates uses SqlCeResult set instead of DataSet, preventing double-buffering of data (causing excessive memory consumption), and improved INSERT and UPDATE performance. When you synchronize data to a SQL Server Compact 3.5 database by using Sync Services for ADO.NET for Devices, the synchronization may be slow

The following SQL Compact hotfix addresses an issue that is commonly encountered when syncing tables with foreign key constraints:
FIX: Error message when an application inserts a value into a foreign key column in SQL Server Compact 3.5: "No key matching the described characteristics could be found within the current range"

Wednesday, March 10, 2010

Requirements for SQL Compact installations on x64 systems

For x64 based computers with SQL Compact, it is important that both the x86 and x64 MSIs are installed and that both the x86 and x64 MSIs are of the same version.

Otherwise you will get errors like: “Version mismatch exception” (new in SQL Compact 3.5 SP2) or “Unable to load DLL ‘sqlceme35.dll’”. Read more here.

Notice that installing Visual Studio 2010 Beta 2 will upgrade the installed version of SQL Compact (3.5 SP1 or 3.5) to 3.5 SP2, but only for x86, so if the x64 version is also installed, it will not be upgraded, causing a version mismatch.